存档

文章标签 ‘Drupal’

从drupal4.7.4换成wordpress2.0.6后好多分类名点击后页面出”404″的错误

2007年1月15日 没有评论

分类显示我用的是permalink(永久链接)的形式

但是发现点进去后

有的分类页面能正常显示

但有更多的分类页面出”404″的错误,好像是说没有找到这个分类的文章

但是实际上这个分类的文章库里肯定是有的

而且页面上分类名后面括号里明显也显示着这个分类的文章数,是远大于”0″的

阅读全文…

分类: 未分类 标签: , ,

系统从drupal倒到wordpress了

2007年1月14日 1 条评论

原来是drupal4.7.4

现在倒成了wordpress2.0.6

感觉原来的drupal太复杂了

还是wordpress简单

分类: 未分类 标签: ,

这几天被一些垃圾站点发过来的垃圾trackback快搞死了

2005年10月25日 没有评论

自定义了几个filter

感觉才好点

否则一个晚上几千条!!!

现在过几天看

都是好几百条待确认的trackback

没办法

懒得一条条看了

直接从数据库里干掉

mysql

use drupal;

delete from trackback_received where status = 0;

commit;

quit

这个世界终于清静了……Smiley

分类: 未分类 标签: ,

drupal下的fckeditor模块儿可真难搞

2005年7月10日 没有评论

自从用了fckeditor for drupal以后

一直也没出什么问题

出了兼容性还有些问题以外(我的ie5.5下就不能显示toolbar)

主要是我也没怎么用

就是字体加粗、改斜体什么的

昨天碰到一个要在文本里加图的问题

点了toolbar里的“插入/编辑图象”按钮后

选“浏览服务器

却发现“/”下什么都没有

而且也不能上传图片

也不能建立目录

后来经过一番折腾

终于搞好了

我一共改了2处

1,按照fckeditor fro drupal文档所讲,修改了文件fckconfig.js,将LinkBrowserURL和ImageBrowserURL分别改成下面这样:

FCKConfig.LinkBrowserURL = FCKConfig.BasePath + "filemanager/browser/default/browser.html?Type=Image&Connector=/modules/fckeditor/ssip/connector.php"
FCKConfig.ImageBrowserURL = FCKConfig.BasePath + "filemanager/browser/default/browser.html?Type=Image&Connector=/modules/fckeditor/ssip/connector.php"

并且修改文件properties.inc,将context_path清空,就像这样:

$properties[‘context_path’] = ”;

2,分析文件properties.inc,发现还需要建立目录/images、/flash、/media,于是在站点主目录下建立了3个子目录,并且赋予apache运行用户可写;且修改变量path_separator为"/",就像这样:

$properties[‘path_separator’] = ‘/’;

分类: 未分类 标签: , ,

Drupal4.6.1的多站点共存在squid+apache环境下的问题

2005年6月23日 没有评论

俺的机器web server是apache

前面用squid做了本地加速

本来跑得好好的

但当我用一套drupal4.6.1的代码跑多(2)个drupal站点的时候

却发生问题了

第二个站点的url(http://www.example2.com)老是显示第一个站点(http://www.example1.com)的内容

但是只要把squid停掉

把apache直接摆到前台

又没有问题

不知道为什么

郁闷

分类: 未分类 标签:

drupal4.6.1中文搜索的问题

2005年6月19日 没有评论

今天晚上偶尔用drupal自带的搜索搜了一把

发现搜中文什么都出不来!!

有点慌了神

google了一把

发现大家都在说drupal的中文搜索不能用

还有的在说在中文字符串前后添加"*"就会好

但也有提到系统crontab任务的问题

于是我"管理"–>"设置"–>"搜索"一看

index果然还是0%

于是我照安装文档上讲的在系统的crontab表里加一条:

0 * * * * wget -O – -q http://www.techtips.cn/cron.php

并手工执行了几遍

wget -O – -q http://www.techtips.cn/cron.php

再看"管理"–>"设置"–>"搜索"

index到了100%

这会儿再在页面上搜索中文

一点问题都没有了

并不需要在中文字符串的前后添加"*"

分类: 未分类 标签: ,

drupal的模块儿article-4.6.0的bug修正

2005年6月13日 没有评论

激活模块儿后,将Latest Article放在页面上,点击其“更多”
页面有显示:
XML Feed

一看html代码
原来上面这行html代码被编码了
html标记“<”、“>”都被编成&什么来着

仔细看了看article.module的代码
发现这个问题很容易解决
找到第162行
把这一句:
$body = theme(‘box’, variable_get(‘article_recent_box_title’, t(‘Latest Articles’)), module_invoke(‘node’, ‘title_list’, article_get_latest(variable_get(‘article_recent_display’, ‘5’)), ”) . theme(‘more_info’, l(“\"XML“, ‘article/feed’)));

改为:
$body = theme(‘box’, variable_get(‘article_recent_box_title’, t(‘Latest Articles’)), module_invoke(‘node’, ‘title_list’, article_get_latest(variable_get(‘article_recent_display’, ‘5’)), ”) . theme(‘more_info’, l(“\"XML“, ‘article/feed’, array(), NULL, NULL, FALSE, TRUE)));

就OK了
其实这里的原因在于l这个函数的调用
他缺省是要把字符串里的html代码编码的
我们调用的时候设定xxx=TRUE
这样不让系统给编码
所以就对了

分类: 未分类 标签: ,